#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:<\s*[\w-]+)*(?:\s([\w-]+)(?:\s*=\s*(?:(?:"((?:(?:\s|\S)*?[^\\])*?)")|(?:'((?:(?:\s|\S)*?[^\\])*?)')))*)*?"
Local $sString = "<tag></tag>" & @CRLF & _
"< tag></ tag>" & @CRLF & _
"<tag></ tag>" & @CRLF & _
"<tag attribute></ tag >" & @CRLF & _
"<tag attribute1 attribute-2 attribute_3 /></tag>" & @CRLF & _
"<tag attribute="value" attribute= "value"></ tag>" & @CRLF & _
"<tag attribute></tag>" & @CRLF & _
"< tag attribute attribute></tag>" & @CRLF & _
"< tag attribute="value" attribute="val\"ue" attribute='val\'ue'></tag>" & @CRLF & _
"<tag attribute></tag>" & @CRLF & _
"<tag attribute attribute></tag>" & @CRLF & _
"<tag attribute="value" attribute="value"></tag>" & @CRLF & _
"< tag attribute="value" attribute="value"></tag>" & @CRLF & _
"< tag attribute="value" attribute ="value" attribute></tag>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")