$re = '/(?:<\s*[\w-]+)*(?:\s([\w-]+)(?:\s*=\s*(?:(?:"((?:(?:\s|\S)*?[^\\\\])*?)")|(?:\'((?:(?:\s|\S)*?[^\\\\])*?)\')))*)*?/m';
$str = '<tag></tag>
< tag></ tag>
<tag></ tag>
<tag attribute></ tag >
<tag attribute1 attribute-2 attribute_3 /></tag>
<tag attribute="value" attribute= "value"></ tag>
<tag attribute></tag>
< tag attribute attribute></tag>
< tag attribute="value" attribute="val\\"ue" attribute=\'val\\\'ue\'></tag>
<tag attribute></tag>
<tag attribute attribute></tag>
<tag attribute="value" attribute="value"></tag>
< tag attribute="value" attribute="value"></tag>
< tag attribute="value" attribute ="value" attribute></tag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);