re = /(?:<\s*[\w-]+)*(?:\s([\w-]+)(?:\s*=\s*(?:(?:"((?:(?:\s|\S)*?[^\\])*?)")|(?:'((?:(?:\s|\S)*?[^\\])*?)')))*)*?/m
str = '<tag></tag>
< tag></ tag>
<tag></ tag>
<tag attribute></ tag >
<tag attribute1 attribute-2 attribute_3 /></tag>
<tag attribute="value" attribute= "value"></ tag>
<tag attribute></tag>
< tag attribute attribute></tag>
< tag attribute="value" attribute="val\\"ue" attribute=\'val\\\'ue\'></tag>
<tag attribute></tag>
<tag attribute attribute></tag>
<tag attribute="value" attribute="value"></tag>
< tag attribute="value" attribute="value"></tag>
< tag attribute="value" attribute ="value" attribute></tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end