// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:<\s*[\w-]+)*(?:\s([\w-]+)(?:\s*=\s*(?:(?:"((?:(?:\s|\S)*?[^\\])*?)")|(?:'((?:(?:\s|\S)*?[^\\])*?)')))*)*?"#).unwrap();
let string = "<tag></tag>
< tag></ tag>
<tag></ tag>
<tag attribute></ tag >
<tag attribute1 attribute-2 attribute_3 /></tag>
<tag attribute=\"value\" attribute= \"value\"></ tag>
<tag attribute></tag>
< tag attribute attribute></tag>
< tag attribute=\"value\" attribute=\"val\\\"ue\" attribute='val\\'ue'></tag>
<tag attribute></tag>
<tag attribute attribute></tag>
<tag attribute=\"value\" attribute=\"value\"></tag>
< tag attribute=\"value\" attribute=\"value\"></tag>
< tag attribute=\"value\" attribute =\"value\" attribute></tag>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}