using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<\s*[\w-]+)*(?:\s([\w-]+)(?:\s*=\s*(?:(?:""((?:(?:\s|\S)*?[^\\])*?)"")|(?:'((?:(?:\s|\S)*?[^\\])*?)')))*)*?";
string input = @"<tag></tag>
< tag></ tag>
<tag></ tag>
<tag attribute></ tag >
<tag attribute1 attribute-2 attribute_3 /></tag>
<tag attribute=""value"" attribute= ""value""></ tag>
<tag attribute></tag>
< tag attribute attribute></tag>
< tag attribute=""value"" attribute=""val\""ue"" attribute='val\'ue'></tag>
<tag attribute></tag>
<tag attribute attribute></tag>
<tag attribute=""value"" attribute=""value""></tag>
< tag attribute=""value"" attribute=""value""></tag>
< tag attribute=""value"" attribute =""value"" attribute></tag>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}