package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:<\s*[\w-]+)*(?:\s([\w-]+)(?:\s*=\s*(?:(?:"((?:(?:\s|\S)*?[^\\])*?)")|(?:'((?:(?:\s|\S)*?[^\\])*?)')))*)*?`)
var str = `<tag></tag>
< tag></ tag>
<tag></ tag>
<tag attribute></ tag >
<tag attribute1 attribute-2 attribute_3 /></tag>
<tag attribute="value" attribute= "value"></ tag>
<tag attribute></tag>
< tag attribute attribute></tag>
< tag attribute="value" attribute="val\"ue" attribute='val\'ue'></tag>
<tag attribute></tag>
<tag attribute attribute></tag>
<tag attribute="value" attribute="value"></tag>
< tag attribute="value" attribute="value"></tag>
< tag attribute="value" attribute ="value" attribute></tag>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}