#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:(?:[2-9]|[1-2]\d|[3][0-5])\^\^(?:\w*\.\w+|\w+(?:\.(?!\.))\w*|\w+))|(?:\d*\.\d+|\d+(?:\.(?!\.))\d*|\d+))(?:(?:``(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))|(?:`(?:(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))?))?(?:\*\^(?:\+|-)?\d+)?"
Local $sString = "// Correct Numbers" & @CRLF & _
"2^^101.101" & @CRLF & _
"35^^WolframLanguage" & @CRLF & _
"16^^dead.Beef" & @CRLF & _
"123`" & @CRLF & _
"1.381`" & @CRLF & _
"16^^9fe.c3`7" & @CRLF & _
"3.0`+7" & @CRLF & _
"3`7" & @CRLF & _
"3.000000000000000000000`7" & @CRLF & _
"3.000000000000000000`-7" & @CRLF & _
"3.98`5*^3" & @CRLF & _
"16^^dead.beef``+4*^-3" & @CRLF & _
"0.0000000001*^10" & @CRLF & _
"35^^small*^-10" & @CRLF & _
"10000000000*^-10" & @CRLF & _
"" & @CRLF & _
"// Non-examples" & @CRLF & _
"1.." & @CRLF & _
"123..." & @CRLF & _
"35^^WolframLanguage" & @CRLF & _
"16^^dead..Beef" & @CRLF & _
"16^^9fe..c3`7" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")