const regex = /(?:(?:(?:[2-9]|[1-2]\d|[3][0-5])\^\^(?:\w*\.\w+|\w+(?:\.(?!\.))\w*|\w+))|(?:\d*\.\d+|\d+(?:\.(?!\.))\d*|\d+))(?:(?:``(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))|(?:`(?:(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))?))?(?:\*\^(?:\+|-)?\d+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:(?:[2-9]|[1-2]\\d|[3][0-5])\\^\\^(?:\\w*\\.\\w+|\\w+(?:\\.(?!\\.))\\w*|\\w+))|(?:\\d*\\.\\d+|\\d+(?:\\.(?!\\.))\\d*|\\d+))(?:(?:``(?:\\+|-)?(?:\\d*\\.\\d+|\\d+\\.\\d*|\\d+))|(?:`(?:(?:\\+|-)?(?:\\d*\\.\\d+|\\d+\\.\\d*|\\d+))?))?(?:\\*\\^(?:\\+|-)?\\d+)?', 'gm')
const str = `// Correct Numbers
2^^101.101
35^^WolframLanguage
16^^dead.Beef
123\`
1.381\`
16^^9fe.c3\`7
3.0\`+7
3\`7
3.000000000000000000000\`7
3.000000000000000000\`-7
3.98\`5*^3
16^^dead.beef\`\`+4*^-3
0.0000000001*^10
35^^small*^-10
10000000000*^-10
// Non-examples
1..
123...
35^^WolframLanguage
16^^dead..Beef
16^^9fe..c3\`7
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}