$re = '/(?:(?:(?:[2-9]|[1-2]\d|[3][0-5])\^\^(?:\w*\.\w+|\w+(?:\.(?!\.))\w*|\w+))|(?:\d*\.\d+|\d+(?:\.(?!\.))\d*|\d+))(?:(?:``(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))|(?:`(?:(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))?))?(?:\*\^(?:\+|-)?\d+)?/m';
$str = '// Correct Numbers
2^^101.101
35^^WolframLanguage
16^^dead.Beef
123`
1.381`
16^^9fe.c3`7
3.0`+7
3`7
3.000000000000000000000`7
3.000000000000000000`-7
3.98`5*^3
16^^dead.beef``+4*^-3
0.0000000001*^10
35^^small*^-10
10000000000*^-10
// Non-examples
1..
123...
35^^WolframLanguage
16^^dead..Beef
16^^9fe..c3`7
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);