# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:(?:[2-9]|[1-2]\d|[3][0-5])\^\^(?:\w*\.\w+|\w+(?:\.(?!\.))\w*|\w+))|(?:\d*\.\d+|\d+(?:\.(?!\.))\d*|\d+))(?:(?:``(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))|(?:`(?:(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))?))?(?:\*\^(?:\+|-)?\d+)?"
test_str = ("// Correct Numbers\n"
"2^^101.101\n"
"35^^WolframLanguage\n"
"16^^dead.Beef\n"
"123`\n"
"1.381`\n"
"16^^9fe.c3`7\n"
"3.0`+7\n"
"3`7\n"
"3.000000000000000000000`7\n"
"3.000000000000000000`-7\n"
"3.98`5*^3\n"
"16^^dead.beef``+4*^-3\n"
"0.0000000001*^10\n"
"35^^small*^-10\n"
"10000000000*^-10\n\n"
"// Non-examples\n"
"1..\n"
"123...\n"
"35^^WolframLanguage\n"
"16^^dead..Beef\n"
"16^^9fe..c3`7\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.