using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:(?:[2-9]|[1-2]\d|[3][0-5])\^\^(?:\w*\.\w+|\w+(?:\.(?!\.))\w*|\w+))|(?:\d*\.\d+|\d+(?:\.(?!\.))\d*|\d+))(?:(?:``(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))|(?:`(?:(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))?))?(?:\*\^(?:\+|-)?\d+)?";
string input = @"// Correct Numbers
2^^101.101
35^^WolframLanguage
16^^dead.Beef
123`
1.381`
16^^9fe.c3`7
3.0`+7
3`7
3.000000000000000000000`7
3.000000000000000000`-7
3.98`5*^3
16^^dead.beef``+4*^-3
0.0000000001*^10
35^^small*^-10
10000000000*^-10
// Non-examples
1..
123...
35^^WolframLanguage
16^^dead..Beef
16^^9fe..c3`7
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}