use strict;
my $str = '// Correct Numbers
2^^101.101
35^^WolframLanguage
16^^dead.Beef
123`
1.381`
16^^9fe.c3`7
3.0`+7
3`7
3.000000000000000000000`7
3.000000000000000000`-7
3.98`5*^3
16^^dead.beef``+4*^-3
0.0000000001*^10
35^^small*^-10
10000000000*^-10
// Non-examples
1..
123...
35^^WolframLanguage
16^^dead..Beef
16^^9fe..c3`7
';
my $regex = qr/(?:(?:(?:[2-9]|[1-2]\d|[3][0-5])\^\^(?:\w*\.\w+|\w+(?:\.(?!\.))\w*|\w+))|(?:\d*\.\d+|\d+(?:\.(?!\.))\d*|\d+))(?:(?:``(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))|(?:`(?:(?:\+|-)?(?:\d*\.\d+|\d+\.\d*|\d+))?))?(?:\*\^(?:\+|-)?\d+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}