# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^(?:https:\\/{2})(?:\w*\.*|\d*\.*)(?:\w*|\d*)*(?:\\/image\\/))(.+)$/https:\/\/newurl.com\/$1/gm;t' <<< "https://url.com/image/img.jpg
https://url.com/image/asdasdasd.jpg
"