const regex = /(?:^(?:https:\/{2})(?:\w*\.*|\d*\.*)(?:\w*|\d*)*(?:\/image\/))(.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(?:https:\\\/{2})(?:\\w*\\.*|\\d*\\.*)(?:\\w*|\\d*)*(?:\\\/image\\\/))(.+)$', 'gm')
const str = `https://url.com/image/img.jpg
https://url.com/image/asdasdasd.jpg
`;
const subst = `https://newurl.com/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);