#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^(?:https:\/{2})(?:\w*\.*|\d*\.*)(?:\w*|\d*)*(?:\/image\/))(.+)$"
Local $sString = "https://url.com/image/img.jpg" & @CRLF & _
"https://url.com/image/asdasdasd.jpg" & @CRLF & _
""
Local $sSubst = "https://newurl.com/$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)