use strict;
my $str = 'https://url.com/image/img.jpg
https://url.com/image/asdasdasd.jpg
';
my $regex = qr/(?:^(?:https:\/{2})(?:\w*\.*|\d*\.*)(?:\w*|\d*)*(?:\/image\/))(.+)$/mp;
my $subst = 'https://newurl.com/$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";