$re = '/(?:^(?:https:\/{2})(?:\w*\.*|\d*\.*)(?:\w*|\d*)*(?:\/image\/))(.+)$/m';
$str = 'https://url.com/image/img.jpg
https://url.com/image/asdasdasd.jpg
';
$subst = "https://newurl.com/$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;