import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?:https:\\/{2})(?:\\w*\\.*|\\d*\\.*)(?:\\w*|\\d*)*(?:\\/image\\/))(.+)$";
final String string = "https://url.com/image/img.jpg\n"
+ "https://url.com/image/asdasdasd.jpg\n";
final String subst = "https://newurl.com/$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}