# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b\d\d:\K(\d\d)[x:\d]?(?=\d\d\b)/$1:/gm;t' <<< "00:21:06,200
00:2106,200 or if 00:21x06,200
00:12345,67"