import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d\\d:\\K(\\d\\d)[x:\\d]?(?=\\d\\d\\b)";
final String string = "00:21:06,200\n"
+ "00:2106,200 or if 00:21x06,200\n"
+ "00:12345,67";
final String subst = "$1:";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}