#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b\d\d:\K(\d\d)[x:\d]?(?=\d\d\b)"
Local $sString = "00:21:06,200" & @CRLF & _
"00:2106,200 or if 00:21x06,200" & @CRLF & _
"00:12345,67"
Local $sSubst = "$1:"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)