$re = '~\b\d\d:\K(\d\d)[x:\d]?(?=\d\d\b)~m';
$str = '00:21:06,200
00:2106,200 or if 00:21x06,200
00:12345,67';
$subst = "$1:";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;