const regex = new RegExp('\\b\\d\\d:\\K(\\d\\d)[x:\\d]?(?=\\d\\d\\b)', 'gm')
const str = `00:21:06,200
00:2106,200 or if 00:21x06,200
00:12345,67`;
const subst = `$1:`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);