import Foundation
let pattern = #"\b\d\d:\K(\d\d)[x:\d]?(?=\d\d\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
00:21:06,200
00:2106,200 or if 00:21x06,200
00:12345,67
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1:"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)