use strict;
my $str = '00:21:06,200
00:2106,200 or if 00:21x06,200
00:12345,67';
my $regex = qr~\b\d\d:\K(\d\d)[x:\d]?(?=\d\d\b)~mp;
my $subst = '$1:';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";