#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?!(?:(?=XYZ)|(?<=X)(?=YZ)|(?<=XY)(?=Z)))."
Local $sString = "abXYxyzXYZabXasdfggXYZ"
Local $sSubst = "+"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)