re = /(?!(?:(?=XYZ)|(?<=X)(?=YZ)|(?<=XY)(?=Z)))./
str = 'abXYxyzXYZabXasdfggXYZ'
subst = '+'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result