using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(?:(?=XYZ)|(?<=X)(?=YZ)|(?<=XY)(?=Z))).";
string substitution = @"+";
string input = @"abXYxyzXYZabXasdfggXYZ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}