import Foundation
let pattern = #"(?!(?:(?=XYZ)|(?<=X)(?=YZ)|(?<=XY)(?=Z)))."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abXYxyzXYZabXasdfggXYZ"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"+"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)