$re = '/(?!(?:(?=XYZ)|(?<=X)(?=YZ)|(?<=XY)(?=Z)))./';
$str = 'abXYxyzXYZabXasdfggXYZ';
$subst = "+";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;