const regex = /(?!(?:(?=XYZ)|(?<=X)(?=YZ)|(?<=XY)(?=Z)))./g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!(?:(?=XYZ)|(?<=X)(?=YZ)|(?<=XY)(?=Z))).', 'g')
const str = `abXYxyzXYZabXasdfggXYZ`;
const subst = `+`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);