use strict;
my $str = 'abXYxyzXYZabXasdfggXYZ';
my $regex = qr/(?!(?:(?=XYZ)|(?<=X)(?=YZ)|(?<=XY)(?=Z)))./p;
my $subst = '+';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";