# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:.*,\s*)?\b([^,]+)\s+\(Observed\).*/\1/gm;t' <<< "Independence Day (Observed)
Christmas Eve, Christmas Day (Observed)
New Year's Eve, New Year's Day (Observed)
Martin Luther King, Jr. Day"