using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*,\s*)?\b([^,]+)\s+\(Observed\).*";
string substitution = @"\1";
string input = @"Independence Day (Observed)
Christmas Eve, Christmas Day (Observed)
New Year's Eve, New Year's Day (Observed)
Martin Luther King, Jr. Day";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}