use strict;
my $str = 'Independence Day (Observed)
Christmas Eve, Christmas Day (Observed)
New Year\'s Eve, New Year\'s Day (Observed)
Martin Luther King, Jr. Day';
my $regex = qr/^(?:.*,\s*)?\b([^,]+)\s+\(Observed\).*/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";