import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*,\\s*)?\\b([^,]+)\\s+\\(Observed\\).*";
final String string = "Independence Day (Observed)\n"
+ "Christmas Eve, Christmas Day (Observed)\n"
+ "New Year's Eve, New Year's Day (Observed)\n"
+ "Martin Luther King, Jr. Day";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}