import Foundation
let pattern = #"^(?:.*,\s*)?\b([^,]+)\s+\(Observed\).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Independence Day (Observed)
Christmas Eve, Christmas Day (Observed)
New Year's Eve, New Year's Day (Observed)
Martin Luther King, Jr. Day
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)