re = /^(?:.*,\s*)?\b([^,]+)\s+\(Observed\).*/m
str = 'Independence Day (Observed)
Christmas Eve, Christmas Day (Observed)
New Year\'s Eve, New Year\'s Day (Observed)
Martin Luther King, Jr. Day'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result