// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:.*,\s*)?\b([^,]+)\s+\(Observed\).*").unwrap();
let string = "Independence Day (Observed)
Christmas Eve, Christmas Day (Observed)
New Year's Eve, New Year's Day (Observed)
Martin Luther King, Jr. Day";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}