# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?'foo'\w*)@(?'Todos_Atrib_Val'(?'Atrib_Val'\w*\|\w*#{0,1})(?'Atrib_Val_Recursivo'\g'Atrib_Val')*)//g;t' <<< "foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN"