const regex = /(?'foo'\w*)@(?'Todos_Atrib_Val'(?'Atrib_Val'\w*\|\w*#{0,1})(?'Atrib_Val_Recursivo'\g'Atrib_Val')*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?\'foo\'\\w*)@(?\'Todos_Atrib_Val\'(?\'Atrib_Val\'\\w*\\|\\w*#{0,1})(?\'Atrib_Val_Recursivo\'\\g\'Atrib_Val\')*)', 'g')
const str = `foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);