import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?'foo'\\w*)@(?'Todos_Atrib_Val'(?'Atrib_Val'\\w*\\|\\w*#{0,1})(?'Atrib_Val_Recursivo'\\g'Atrib_Val')*)";
final String string = "foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}