re = /(?'foo'\w*)@(?'Todos_Atrib_Val'(?'Atrib_Val'\w*\|\w*#{0,1})(?'Atrib_Val_Recursivo'\g'Atrib_Val')*)/
str = 'foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result