use strict;
my $str = 'foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN';
my $regex = qr/(?'foo'\w*)@(?'Todos_Atrib_Val'(?'Atrib_Val'\w*\|\w*#{0,1})(?'Atrib_Val_Recursivo'\g'Atrib_Val')*)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";