package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?'foo'\w*)@(?'Todos_Atrib_Val'(?'Atrib_Val'\w*\|\w*#{0,1})(?'Atrib_Val_Recursivo'\g'Atrib_Val')*)`)
var str = `foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}