using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'foo'\w*)@(?'Todos_Atrib_Val'(?'Atrib_Val'\w*\|\w*#{0,1})(?'Atrib_Val_Recursivo'\g'Atrib_Val')*)";
string substitution = @"";
string input = @"foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}