#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\[[\s\n\r]*\{|\},[\s\n\r]+\{|\}[\s\n\r]*\])"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "Assigned to": "Jones, Francis"," & @CRLF & _
" "Cost": 3," & @CRLF & _
" "Created date": "2024-02-28 12:52:18"," & @CRLF & _
" "Extraction date": "2024-03-02 13:51:00"," & @CRLF & _
" "ID": 12345," & @CRLF & _
" "Initial Cost": 3," & @CRLF & _
" "Location": "Sites"," & @CRLF & _
" "Path": "Sites\\FY1\\S3"," & @CRLF & _
" "Priority": 1," & @CRLF & _
" "State": "In Progress"," & @CRLF & _
" "Status Change date": "2024-03-05 16:33:23"," & @CRLF & _
" "Tags": "Europe; Finance"," & @CRLF & _
" "Title": "Ensure correct routing of orders"," & @CRLF & _
" "Updated date": "2024-03-05 16:33:23"," & @CRLF & _
" "Warranty": false," & @CRLF & _
" "Wave Quarter": "Q2 22"," & @CRLF & _
" "Work Item Type": "Request"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "Assigned to": "Jones, Francis"," & @CRLF & _
" "Cost": 3," & @CRLF & _
" "Created date": "2024-02-28 18:59:18"," & @CRLF & _
" "Extraction date": "2024-03-05 16:31:00"," & @CRLF & _
" "ID": 12345," & @CRLF & _
" "Initial Cost": 3," & @CRLF & _
" "Location": "Sites"," & @CRLF & _
" "Path": "Sites\\FY1\\S3"," & @CRLF & _
" "Priority": 1," & @CRLF & _
" "State": "In Progress"," & @CRLF & _
" "Status Change date": "2024-03-05 16:33:23"," & @CRLF & _
" "Tags": "Europe; Finance"," & @CRLF & _
" "Title": "Ensure correct routing of orders"," & @CRLF & _
" "Updated date": "2024-03-05 16:33:23"," & @CRLF & _
" "Warranty": false," & @CRLF & _
" "Wave Quarter": "Q2 22"," & @CRLF & _
" "Work Item Type": "Request"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "Assigned to": "Jones, Francis"," & @CRLF & _
" "Cost": 3," & @CRLF & _
" "Created date": "2023-01-28 18:59:18"," & @CRLF & _
" "Extraction date": "2023-02-05 16:31:00"," & @CRLF & _
" "ID": 12345," & @CRLF & _
" "Initial Cost": 3," & @CRLF & _
" "Location": "Sites"," & @CRLF & _
" "Path": "Sites\\FY1\\S3"," & @CRLF & _
" "Priority": 1," & @CRLF & _
" "State": "In Progress"," & @CRLF & _
" "Status Change date": "2023-02-05 16:33:23"," & @CRLF & _
" "Tags": "Europe; Finance"," & @CRLF & _
" "Title": "Ensure correct routing of orders"," & @CRLF & _
" "Updated date": "2024-03-05 16:33:23"," & @CRLF & _
" "Warranty": false," & @CRLF & _
" "Wave Quarter": "Q2 22"," & @CRLF & _
" "Work Item Type": "Request"" & @CRLF & _
" }" & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")