$re = '/(\[[\s\n\r]*\{|\},[\s\n\r]+\{|\}[\s\n\r]*\])/m';
$str = '[
{
"Assigned to": "Jones, Francis",
"Cost": 3,
"Created date": "2024-02-28 12:52:18",
"Extraction date": "2024-03-02 13:51:00",
"ID": 12345,
"Initial Cost": 3,
"Location": "Sites",
"Path": "Sites\\\\FY1\\\\S3",
"Priority": 1,
"State": "In Progress",
"Status Change date": "2024-03-05 16:33:23",
"Tags": "Europe; Finance",
"Title": "Ensure correct routing of orders",
"Updated date": "2024-03-05 16:33:23",
"Warranty": false,
"Wave Quarter": "Q2 22",
"Work Item Type": "Request"
},
{
"Assigned to": "Jones, Francis",
"Cost": 3,
"Created date": "2024-02-28 18:59:18",
"Extraction date": "2024-03-05 16:31:00",
"ID": 12345,
"Initial Cost": 3,
"Location": "Sites",
"Path": "Sites\\\\FY1\\\\S3",
"Priority": 1,
"State": "In Progress",
"Status Change date": "2024-03-05 16:33:23",
"Tags": "Europe; Finance",
"Title": "Ensure correct routing of orders",
"Updated date": "2024-03-05 16:33:23",
"Warranty": false,
"Wave Quarter": "Q2 22",
"Work Item Type": "Request"
},
{
"Assigned to": "Jones, Francis",
"Cost": 3,
"Created date": "2023-01-28 18:59:18",
"Extraction date": "2023-02-05 16:31:00",
"ID": 12345,
"Initial Cost": 3,
"Location": "Sites",
"Path": "Sites\\\\FY1\\\\S3",
"Priority": 1,
"State": "In Progress",
"Status Change date": "2023-02-05 16:33:23",
"Tags": "Europe; Finance",
"Title": "Ensure correct routing of orders",
"Updated date": "2024-03-05 16:33:23",
"Warranty": false,
"Wave Quarter": "Q2 22",
"Work Item Type": "Request"
}
]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);