import Foundation
let pattern = #"(\[[\s\n\r]*\{|\},[\s\n\r]+\{|\}[\s\n\r]*\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[
{
"Assigned to": "Jones, Francis",
"Cost": 3,
"Created date": "2024-02-28 12:52:18",
"Extraction date": "2024-03-02 13:51:00",
"ID": 12345,
"Initial Cost": 3,
"Location": "Sites",
"Path": "Sites\\FY1\\S3",
"Priority": 1,
"State": "In Progress",
"Status Change date": "2024-03-05 16:33:23",
"Tags": "Europe; Finance",
"Title": "Ensure correct routing of orders",
"Updated date": "2024-03-05 16:33:23",
"Warranty": false,
"Wave Quarter": "Q2 22",
"Work Item Type": "Request"
},
{
"Assigned to": "Jones, Francis",
"Cost": 3,
"Created date": "2024-02-28 18:59:18",
"Extraction date": "2024-03-05 16:31:00",
"ID": 12345,
"Initial Cost": 3,
"Location": "Sites",
"Path": "Sites\\FY1\\S3",
"Priority": 1,
"State": "In Progress",
"Status Change date": "2024-03-05 16:33:23",
"Tags": "Europe; Finance",
"Title": "Ensure correct routing of orders",
"Updated date": "2024-03-05 16:33:23",
"Warranty": false,
"Wave Quarter": "Q2 22",
"Work Item Type": "Request"
},
{
"Assigned to": "Jones, Francis",
"Cost": 3,
"Created date": "2023-01-28 18:59:18",
"Extraction date": "2023-02-05 16:31:00",
"ID": 12345,
"Initial Cost": 3,
"Location": "Sites",
"Path": "Sites\\FY1\\S3",
"Priority": 1,
"State": "In Progress",
"Status Change date": "2023-02-05 16:33:23",
"Tags": "Europe; Finance",
"Title": "Ensure correct routing of orders",
"Updated date": "2024-03-05 16:33:23",
"Warranty": false,
"Wave Quarter": "Q2 22",
"Work Item Type": "Request"
}
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)