// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\[[\s\n\r]*\{|\},[\s\n\r]+\{|\}[\s\n\r]*\])").unwrap();
let string = "[
{
\"Assigned to\": \"Jones, Francis\",
\"Cost\": 3,
\"Created date\": \"2024-02-28 12:52:18\",
\"Extraction date\": \"2024-03-02 13:51:00\",
\"ID\": 12345,
\"Initial Cost\": 3,
\"Location\": \"Sites\",
\"Path\": \"Sites\\\\FY1\\\\S3\",
\"Priority\": 1,
\"State\": \"In Progress\",
\"Status Change date\": \"2024-03-05 16:33:23\",
\"Tags\": \"Europe; Finance\",
\"Title\": \"Ensure correct routing of orders\",
\"Updated date\": \"2024-03-05 16:33:23\",
\"Warranty\": false,
\"Wave Quarter\": \"Q2 22\",
\"Work Item Type\": \"Request\"
},
{
\"Assigned to\": \"Jones, Francis\",
\"Cost\": 3,
\"Created date\": \"2024-02-28 18:59:18\",
\"Extraction date\": \"2024-03-05 16:31:00\",
\"ID\": 12345,
\"Initial Cost\": 3,
\"Location\": \"Sites\",
\"Path\": \"Sites\\\\FY1\\\\S3\",
\"Priority\": 1,
\"State\": \"In Progress\",
\"Status Change date\": \"2024-03-05 16:33:23\",
\"Tags\": \"Europe; Finance\",
\"Title\": \"Ensure correct routing of orders\",
\"Updated date\": \"2024-03-05 16:33:23\",
\"Warranty\": false,
\"Wave Quarter\": \"Q2 22\",
\"Work Item Type\": \"Request\"
},
{
\"Assigned to\": \"Jones, Francis\",
\"Cost\": 3,
\"Created date\": \"2023-01-28 18:59:18\",
\"Extraction date\": \"2023-02-05 16:31:00\",
\"ID\": 12345,
\"Initial Cost\": 3,
\"Location\": \"Sites\",
\"Path\": \"Sites\\\\FY1\\\\S3\",
\"Priority\": 1,
\"State\": \"In Progress\",
\"Status Change date\": \"2023-02-05 16:33:23\",
\"Tags\": \"Europe; Finance\",
\"Title\": \"Ensure correct routing of orders\",
\"Updated date\": \"2024-03-05 16:33:23\",
\"Warranty\": false,
\"Wave Quarter\": \"Q2 22\",
\"Work Item Type\": \"Request\"
}
]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}